Jump to content
Sign in to follow this  
Kira

Windows 7 Crashes

Recommended Posts

About six months ago (random wild guess), I started experiencing un-commanded system shutdowns, followed within 10 seconds by an un-hard-commanded (ie manually push the power button, this was not done) restart once the system had apparently re-set itself.  Over months, this became more and more frequent, to the tune of now I'm getting I'm guessing an average of once an hour.  That's an average, and not an exaggeration, though maybe it's more like every two hours.  Of note is the fact that it doesn't seem to do it when using the internet, only when running programs (games), of which, mine tend to be pretty CPU etc. heavy.  It probably has something to do with somewhere these programs are looking so that they can run correctly, that the internet isn't looking - and the file(s) is/are corrupted or missing.

 

I looked up the fix, and computerhope.com had some recommendations, one of which had to do with the fact that starting with Windows XP (I think), the code was changed such that any time a fault in the Windows program was detected, it automatically shut down and restart Windows, hence the uncommanded shutdown/restart.

 

Now that I knew why the problem was occuring, I set about fixing it.  So i followed their directions, and went in and turned off this feature, so no more automatic shutdowns.  Great, I'm good, right?  Wrong.  I double checked that the feature was shut down. It is.  And it STILL does this shutdown/restart BS.

 

Late this past week, I'd had enough.  This weekend, I told the gang, I'm going to pull everything critical onto my 2TB external, disconnect it, and do a totally fresh Windows 7 install on the OS drive.  Great.

 

Epiphany:  Wait a minute, there's a "fix" feature on the OS disk!  I can just run said "fix" feature and it'll replace the corrupted/missing files with the right ones, no fresh start required!

 

It's not there.  The "fix" option isn't available.  What?  What's going one?  "This version of Windows is not compatable with your installed version."  It's. The.  Same. DISK!  I only have one!  There's no mistaking it.  This was the disk used to install this copy of Windows 7.

 

Any suggestions?  I'm within a gnats eyelash of continuing with my original fresh install plan, but what the heck, thought I'd ask.  Thanks all.

Share this post


Link to post
Share on other sites

I'm guessing your disk is pre-service pack 1 and your system is now post-service pack 1?

 

Back everything up and go for an install.

Share this post


Link to post
Share on other sites

I'm guessing your disk is pre-service pack 1 and your system is now post-service pack 1?

 

Back everything up and go for an install.

 

Oops ... consider this thread being a bit behind... we talked on TS yesterday, and as the restarts are just that - no BSOD, no shutdown - we are inclined to think Power - and specifically a rather old surge-protector that he is using... so ... let's wait for Kira to report whether it helped ....  :shaunhb:

Share this post


Link to post
Share on other sites

Well, the plug switch within the surge protector didn't work.  I was able to determine, however, that the surge protector likely still had power, and thus was likely not the source of the problem.  This leads me to believe some sort of BIOS (?) issue, meaning a Windows re-install is the likely recourse.  Either that, or the cat is developing telepathic powers.    This time, he wasn't sitting on the tower, but merely looking at it.  Yup.  Must be the cat.

 

Serious thought, it might be that with the PC and air conditioner pulling from the same outlet, it's asking too much, dropping enough power for the PC to cut out, but not the surge protector or air conditioning unit.  I've put the PC on a separate outlet to see it that solves the problem.  We shall see, though I have my doubts, as the setup I had has never caused issues before.

Share this post


Link to post
Share on other sites

Windows reinstall won't fix a BIOS problem mate

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Well, it's definitely the PC in someway shape, or form.  I have it drawing off an independent outlet, and it's crashed several times, once immediately after restart at the "Windows has recovered from an unexpected shutdown" screen.

Share this post


Link to post
Share on other sites

Check the event log for errors?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Well, it states 'unexpected shutdown', so I doubt there's anything in the event log...

 

Me thinks PSU... Replacing it is a gamble though. Could also be motherboard...

 

What if you'd boot it from like a Kaspersky rescue CD/DVD/USB stick.

 

Just let it sit, see if it still reboots. If it does not, then the OS could be the culprit... if it does reboot, then it's definitely hardware...

Share this post


Link to post
Share on other sites

"Just letting it sit" hasn't and thus likely wouldn't cause a problem though.  It seems only when it's computing ie running programs that it crashes.

 

Kaspersky rescue states it's for computers that won't start up.  This one does fine.  Unless the secondary about a startup virus is part of the equation?

Share this post


Link to post
Share on other sites

How running something like ubuntu from a memory stick - that's more like a proper OS. Remember that recently I changed the PSU after some similar errors but it wound up being the mobo.

Share this post


Link to post
Share on other sites

I had a thought.  When "re-building" this computer, that is tearing the guts out and replacing everything except the case (which I paid waayyy too much for originally), I made a major error.  (This was two or three years ago now, I suspect.)  I ended up tearing out the power button from the case.  Immediately afterward, I realized my mistake.  Duh, dummy, that plug goes into the board, and the reason it's hot glued into the case so ridiculously so as if it was never designed to come out is because - (surprise!) - it was never designed to come out.  Long story short, I rigged it up, and got it to work again, but I'll be willing to bet that some failure in that power switch has finally caught up and is connecting when the button's not being pushed, thus turning the computer off.

Share this post


Link to post
Share on other sites

You have done all the usual stuff, like reseating the ram and running memtest?

Another one that bit me a few years ago was a degraded SATA cable.

Had another recently with daughters PC, cable dragged drive read/write times to 10% of spec

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×