Jump to content
Sign in to follow this  
DD_Fenrir

DCS 2.5

Recommended Posts

So...

Thanks to a facebook post by ED we can be confident to expect the Open Beta of 2.5 to land on the 31st of January. Wh00t!

However, this does not necessarily mean you will be able to access it! 

The 31st Update will only update the 1.5.8 Open Beta install to 2.5 Open Beta.

If you have a release version of 1.5.8 - which I suspect is most of you - then you will have to wait until the open beta version of 2.5 is proved bug free (or non-critical bugs) and then it will update your 1.5.8 version automatically to 2.5 release as and when it is made available. This could be at minimum a week, probably longer.

The update path is described here: https://forums.eagle.ru/showthread.php?t=200340

The upshot of this is if you want to access 2.5 Open Beta on the 31st you will have to have installed the 1.5.8 Open Beta. There are two ways to accomplish this:

1. Download and install the Open Beta version found here: https://www.digitalcombatsimulator.com/en/downloads/world/beta/

It should not take long as it will copy all of the files from your release version. You can then copy the inputs folder from your C:\Users\<username>\Saved Games\DCS into the parallel DCSOpenBeta folder. 

The bad with this is that

(i) you will require the HD space to run this as a second instance of DCS and given that predictions are putting the total size of the DCS 2.5 Open Beta install at ~100GB, that's no insignificant amount of space, particularly if you installed to a 128GB SSD and already have 80 odd GB of DCS 1.5.8 release installed!

(ii) you will have to activate your modules again within the Open Beta. 

2. You can force the updater to update your 1.5.8 release install and turn it into a 1.5.8 Open Beta - see instructions here: https://forums.eagle.ru/showthread.php?t=114030

Positives are that it saves on disk space and there's no need to transfer across control input settings or reactivate modules. 

However, as outlined in the above post it requires experience using the command prompt and careful following of the syntax described, with a serious risk of kiboshing your DCS install if it goes wrong.

Also if it goes ok you will only be able to multiplayer with others using the same version as the Open Beta - sometimes both the Release and Open Beta are on the same version, which is great. Much of the time, however, the Beta tends to be a version ahead so you woould not be able to host or join servers with other DDz who are on the Release version. 

Some of you might feel it best waiting it out and if I'm honest it would save some hassle. If I do it I have to take Option 1 as my new rig only has 2.2 Open Alpha installed currently.

Those of you with 2.2 Open Alpha, I quote Riks here: "this branch is no longer supported. If user have only 2.2.0 Open Alpha, updater will suggest to download 2.5 installer - it will install 2.5 release and remove 2.2.0 Open Alpha"

Again this means that 2.2 Open Alpha will have to await the Release version of 2.5. If you wish to access 2.5 Open Beta and do not have a 1.5.8 Open Beta version, then Option 1 is your only choice.

Clear as mud? 

Share this post


Link to post
Share on other sites
Just now, DD_Fenrir said:

Clear as mud? 

Blimey.

Think I might wait for the official release of 2.5 now.:wacko: 

Share this post


Link to post
Share on other sites

Too much faff for me, going to wait for 2.5 official release. :wacko:

Share this post


Link to post
Share on other sites
Just now, Crash said:

We have had a lot of practice waiting for stuff :)

It does seem to be the universal flightsim experience... well that and crashing.

Share this post


Link to post
Share on other sites

Yep, and dont forget the poor sods who backed Star Citizen God knows how long they are going to wait.

Share this post


Link to post
Share on other sites

12.3Gb! Holy moly!

I'mma need a new HDD :rolleyes:

Share this post


Link to post
Share on other sites
22 minutes ago, BluBear said:

12.3Gb! Holy moly!

I'mma need a new HDD :rolleyes:

The fun never ends

Share this post


Link to post
Share on other sites

Downloading now.  Just realised I've been running the 1.5 open beta anyway.  Doh!:wacko:

Share this post


Link to post
Share on other sites

Ahhh...ok, I think I need at least a new graphics card:P

Share this post


Link to post
Share on other sites

Looking forward to the final version as I will be able to use the Oclus controllers to flip the switches :)

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×