Jump to content
Sign in to follow this  
Friar

Windows 10 Update 1511 And X52 - Watch Out!

Recommended Posts

My X52Pro is nerfed following a windows 10 update yesterday.

Looking around tinternet I found this.....

After the major Windows 10 update (build 1511) my Saitek x52 Pro didn't work anymore. I tried to reinstall, but the installer just hangs and did not detect the X52 being plugged in. After a lot of trial and error I found a fix...

 

Try this short version first:

- Connect X52

- Open device manager -> look for an USB input device with an ! 

- Right click: update driver

- Choose "search on my PC" and then "let me pick" (2nd option) -> you get a list of 2 compatible devices

- Now select the 1st option "USB input device" or something similar NB: NOT the 2nd one with USB X52 in the name!!!

- Device should work now...

 

If this does not work: this is the long version which was the first way I found to get it working again:

- Plugin the X52

- Go to device manager and delete the X52 and USB devices with an ! sign (warning/not installed correctly)

- Restart your PC

- Unplug your X52

- Run the installer (with the latest beta drivers for W10)

- When the screen pops up with the instruction to plugin your X52 -> plug it in...

- Just let the installer run (with the NEXT button greyed out) and go to device manager

- Right click on the X52 device and select update driver

- Choose "search on my PC" and then "let me pick" (2nd option) -> you get a list of 2 compatible devices

- Now select the 1st option "USB device" or something similar NB: NOT the 2nd one with USB X52 in the name!!!

- Directly after this W10 detects your X52 and you can select NEXT in the installer

- Install will continue and finish correctly

 

The right selection of the USB device (AND NOT X52..) is important. If you select the X52 line you get a critical error and it stops..

 

At first the problem returned after a complete power down and restart in the morning of Windows. After reading about problems with USB I disabled FAST START and this seems a permanent fix for me. It seems that Windows starts too fast for USB devices to report themselves and to be enabled.. You can find this option here: Energy management -> behaviour of on/off buttons -> Fast start is greyed out, but if you select "choose options which are not available right now" you can disable it.

 

It solved the problem for me (hopefully permanently), hope it helps others too!

 

I reported this problem to Mad Catz...but maybe it is more a Microsoft problem...

 

Cheers,

 

 

I am just about to go through the process now...........:(

 

Friar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×